Illustrativemathematics.org and Illustrativemathematics.blog have major outages.

Incident Report for Illustrative Mathematics

Resolved

Working with our hosting providers, service has been restored.
Posted Mar 13, 2024 - 20:29 UTC

Investigating

We are currently investigating this issue.
Posted Mar 13, 2024 - 20:11 UTC
This incident affected: IM Website and Blog (IM Website (uptime monitoring), IM Blog (uptime monitoring)).