The incident with AWS appears to be resolved, and new users can now register.
Posted Dec 08, 2021 - 00:48 UTC
Identified
Due to an issue with one of our hosting providers, AWS (https://status.aws.amazon.com/), users may not be able to register for new accounts on the Kendall Hunt instance. Once AWS resolves their issues, the site should return to normal functionality.
Posted Dec 07, 2021 - 21:16 UTC
This incident affected: Curriculum Sites (Kendall Hunt, IM Demo) (KH instance (uptime monitoring)).